Jump to content
highcenbug

Updating jQuery

Recommended Posts

Hi,

 

I ran my site on https://gf.dev/wordpress-security-scanner and the results showed that the jQuery version is still at jQuery@1.12.4. What plugin or how do I update the jQuery on the theme? My client's site is using version 4.9.6.2. The site is hosted on GCP.


Thanks

Share this post


Link to post
Share on other sites

Hey @highcenbug, I can tell you that MD does not load jQuery in the theme so we will have to take a look at your plugins. The last time I checked WordPress doesn't load the latest jQuery version, and if your plugins are loading WP's version then that is why.

To debug this, try installing the Query Monitor free plugin and check if it reports the source of jQuery, otherwise you can disable your plugins one by one until it no longer loads to your site, then you will know where it is coming from.


- Alex
Check out the MD blog and follow me on Twitter.

Share this post


Link to post
Share on other sites

Ok so most certainly WooCommerce is loading jQuery. I have personally not heard of security holes through running older versions of jQuery, and my line of thinking is that if WordPress and WooCommerce both have this version of jQuery that it is probably safe to use. Otherwise, we will have to dequeue (stop loading) their version of jQuery and manually load our own, which could be risky and break some functionality.

So the question is, what security concerns are you concerned about?


- Alex
Check out the MD blog and follow me on Twitter.

Share this post


Link to post
Share on other sites

Yes, and I am asking you of anything specific in that outdated, yet shipped version of jQuery that you are concerned about. I did a little research and found an actively maintained plugin that allows you to change the version of jQuery: https://wordpress.org/plugins/jquery-manager/

  • Like 1

- Alex
Check out the MD blog and follow me on Twitter.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...