Unable to update them due to layout issues arising

awrmedia

MD customer
Messages
21
Reaction score
4
Hi,

We tried to update MD theme at www.izaa.nl but then rightaway the entire site layout looked like s***. Re-implementing the correct stylesheet didn't solve the problem. Any ideas how to troubleshoot this problem? I have to admit that I have no idea where to start.

Thanks in advance.

Peter

 

Alex

MD developer
Messages
4,883
Reaction score
1,138
Hi Peter, can you describe what you mean when you say the layout looks like shit? In case the stylesheet went blank, when you update click the updater link in the yellow nag that appears at the top of the Themes panel and make sure the admin page refreshes.

Otherwise, it looks like you are running a fairly recent version of MD so the update should go smoothly. Let me know if a more specific problem is happening.

 

awrmedia

MD customer
Messages
21
Reaction score
4
Thanks for answering Alex. Unfortunately it didn't work. Or I don't quite understand what to do exactly. I don't see any yellow nags so far but I might be looking in the wrong place.

Anyhow I've included a screenshot of the result (before we restored our backup that is) so I hope you don't mind to take a look.

distorted izaa after md theme update.jpg

 

Alex

MD developer
Messages
4,883
Reaction score
1,138
No problem - if you see this after an update immediately go to MD > Settings and save the options. This will rebuild the stylesheet and should get you back on track.

If that doesn't work, go to MD > Settings > Site Performance and enable "Print inline CSS" to see if that works.

 

awrmedia

MD customer
Messages
21
Reaction score
4
Thanks for replying. Unfortunately, bad news. Tried both, same wrecked up result.

 

Alex

MD developer
Messages
4,883
Reaction score
1,138
Ok, I see you have some kind of minify/cache plugins on your site. Can you try disabling at least the minification plugin so all CSS files load as normal? The issue isn't that your site is truly messed up, fortunately, there just seems to be something preventing the new CSS from being built and those plugins are usually the culprits.

 

awrmedia

MD customer
Messages
21
Reaction score
4
Tried updating with all plugins off. Didn't help. 

Any thoughts? Issue keeps us of the street though.

 

awrmedia

MD customer
Messages
21
Reaction score
4
Bump. Tried updating with the latest version. Even changed cache plugin. Doesn't do anything for the better. I see more people having layout issues after updating.
 

Maikel

MD support
Messages
163
Reaction score
76
This is what i always do after i update my website (I start with the same result as you do). Some things are the same as Alex also mentioned above.

1. Go to Marketers Delight in the dasboard and click on "Save Settings".
2. Clear the whole cache of my caching plugin.
3. I always do a hard refresh. CMD + R (mac) or CTRL + F5 (Windows).

Also i suggest to always test an update on a staging website. It's not fun to deal with this on your live website and MD5 is a big update, so maybe some customizations are not working anymore.
 

Alex

MD developer
Messages
4,883
Reaction score
1,138
Hey @awrmedia sorry this still hasn't been resolved. My best guess right now is that it has something to do with minify or caching, both of which should be removed until after updating and after you have determined your site is OK.

What is happening is after the update, MD needs to rebuild its dynamic stylesheet which requires at least one page load in the admin panel to do. So after you update, go to the MD settings panel to read what's new, or click to any other admin page. That is why I encourage to always use the yellow update message at the top of the Appearance > Themes page to update MD because it refreshes the page for you.

If the stylesheet doesn't get a chance to update, or a minify/cache plugin has hijacked how stylesheets get loaded, the result will be the blank/broken page we see on your website.

I just wanted to explain that in more detail to hopefully trigger a solution on your end. If not then it may require an admin login so I can see for myself.
 

awrmedia

MD customer
Messages
21
Reaction score
4
Tried as you suggested. Also updated database. Didn't do a thing. Although we've managed to come a bit further than before. Instead of NO layout we not get a distorted layout (see pics). So we backupped once again. Mind peeking?
 

Attachments

Maikel

MD support
Messages
163
Reaction score
76
I can check it for you. You can DM me with login credentials (we can also talk Dutch there if you want).
On what version of MD are you right now? If you are below MD 5 and did some customizations, there is a possibility that you need to need to change a few things after updating.
 

Alex

MD developer
Messages
4,883
Reaction score
1,138
@Maikel if we need to work together on this loop me in and I'd be happy to find the solution.
 

Maikel

MD support
Messages
163
Reaction score
76
It's fixed.

The solution: In this case the header.php file of the child theme was outdated. Because of that, the <head> section of the website didn't load anymore. After updating the header.php file in the child theme everything was back to normal.
 

Alex

MD developer
Messages
4,883
Reaction score
1,138
It's fixed.

The solution: In this case the header.php file of the child theme was outdated. Because of that, the <head> section of the website didn't load anymore. After updating the header.php file in the child theme everything was back to normal.
Incredible! Thank you for tracking this down.
 
Top