• Welcome to the official support community for the Marketers Delight WordPress theme. Most content here is private and to ask questions, get official support, and network with other WordPress users please register and verify your forum account to start posting today.

Not getting the data in my test server.

Alex

MD developer
Messages
5,841
Reaction score
1,639
We need more information about your setup. Make sure you review 1) API user permissions from XenForo admin 2) Copy the correct API keys to XF settings in WordPress 3) Press "Refresh forum data" to sync

Read the setup guide:

 
Comment

Deepak Verma

Member
Messages
7
Reaction score
0
We need more information about your setup. Make sure you review 1) API user permissions from XenForo admin 2) Copy the correct API keys to XF settings in WordPress 3) Press "Refresh forum data" to sync

Read the setup guide:

I had did this steps that is working on my another server but in my test server that is not i had did these steps also but in my test server that is not working.
 
Comment

Alex

MD developer
Messages
5,841
Reaction score
1,639
I had did this steps that is working on my another server but in my test server that is not i had did these steps also but in my test server that is not working.
Do you have any error messages from the server or browser console you can share? I can't offer much assistance without further details or screenshots. It sounds like somethjng with the test server API setup is not correct.
 
Comment

Deepak Verma

Member
Messages
7
Reaction score
0
I had attached the two screeshot for the reference first screenshot every thing working perfectly and api user permission connected but in my another screenshot no api user permission connected and this is my test server and i have put the correct 1) API user permissions from XenForo admin 2) Copy the correct API keys to XF settings in WordPress 3) Press "Refresh forum data" to sync but data not sync.
 

Attachments

  • Screenshot 2021-09-13 at 10-27-48 XenForo ‹ devDiscuss — WordPress.png
    Screenshot 2021-09-13 at 10-27-48 XenForo ‹ devDiscuss — WordPress.png
    4.7 KB · Views: 7
  • Screenshot_18.png
    Screenshot_18.png
    6 KB · Views: 7
Comment

Alex

MD developer
Messages
5,841
Reaction score
1,639
In the link you posted I see index.php in the site URLs. You may need to switch on the "Use full friendly URLs" in XenForo Admin > Setup > Basic Options
 
Comment

Deepak Verma

Member
Messages
7
Reaction score
0
In the "Board Url" i am remove the index.php and follow "The primary URL to board. Do not include a trailing "/" or "index.php". " I had attached the screenshot for your reference.
 
Comment

Deepak Verma

Member
Messages
7
Reaction score
0
yes i had create the super user key. yes i had add the user id also into the xftowp setting but still not getting the data sync user id is optional.
 

Attachments

  • Screenshot 2021-09-14 at 15-42-16 XenForo ‹ devDiscuss — WordPress.png
    Screenshot 2021-09-14 at 15-42-16 XenForo ‹ devDiscuss — WordPress.png
    2.9 KB · Views: 5
Comment

Deepak Verma

Member
Messages
7
Reaction score
0
No there is no folder call api, folder in your xenforo direction called api, delete it. This will not connect to this server in my cloud server that is working properly that i mention earlier.
 
Comment
Top