• Welcome to the official support community for the Marketers Delight WordPress theme. Most content here is private and to ask questions, get official support, and network with other WordPress users please register and verify your forum account to start posting today.

Fixed New forum replies are not syncing on wordpress

Millard

Member
Messages
10
Reaction score
1
I was able to create a new xf thread from a wordpress post yesterday. I set the thread comments interval for 10 minutes. But the xf replies are not syncing with wordpress.

Maybe related, I have not been able to create new threads from wordpress today. I can only link to existing threads. The thread comments still do not sync. The only way i can sync is to disconnect the thread and then reconnect.

The "click to expand" and "load more replies" buttons are not working either.

My API has these permissions : thread:read thread:write node:read
Am I missing something?

Thank you
 

Alex

MD developer
Messages
5,522
Reaction score
1,443
Most issues are unfortunately caused by cache plugins but there have been some workarounds we have found to help. If your cache plugin has a setting where you can add hooks to automatically clear cache after they are run you can add XFtoWP's update option hook to its whitelist:

CSS:
update_post_meta
update_option_xfwp

You should also try disabling Object caching if you have it enabled to see if that helps.
 
Comment

Millard

Member
Messages
10
Reaction score
1
The issues were solved when the caching plugin was disabled.

Unfortunately, I may have created another problem.

I somehow removed "Xeforo forum" options from the Document Settings panel. Could this have been the cause of the following that occurred immediately afterward? :

I am no longer able to Connect Threads or Create Threads.

I receive the message "Please enter a Thread ID" after entering a valid thread ID to connect.
I receive a "The requested thread could not be found" error on xenforo after trying to create a new thread.

How can I restore the XFtoWP options back to the Document Settings panel? Thanks!

 
Last edited:
Comment

Alex

MD developer
Messages
5,522
Reaction score
1,443
The issues were solved when the caching plugin was disabled.

Unfortunately, I may have created another problem.

I somehow removed "Xeforo forum" options from the Document Settings panel. Could this have been the cause of the following that occurred immediately afterward? :

I am no longer able to Connect Threads or Create Threads.

I receive the message "Please enter a Thread ID" after entering a valid thread ID to connect.
I receive a "The requested thread could not be found" error on xenforo after trying to create a new thread.

How can I restore the XFtoWP options back to the Document Settings panel? Thanks!

There is a funny quirk with the Gutenberg editor in WordPress and the XF meta box must remain in the small sidebar panel to the right. I have noted this as a bug report and will try to find a workaround.
 
Comment

Millard

Member
Messages
10
Reaction score
1
I'd prefer to have it in the sidebar panel. How do I return it to its original location?

I removed it from the sidebar panel by accident. Honestly, I have no idea how it happened!
 
Comment

Alex

MD developer
Messages
5,522
Reaction score
1,443
I'd prefer to have it in the sidebar panel. How do I return it to its original location?

I removed it from the sidebar panel by accident. Honestly, I have no idea how it happened!
Yeah it's weird because I made sure to register the meta box to show on the side. This new editor is always changing in each WP update so you never know what weird quirks may have caused it.

You should be able to drag and drop the XenForo box over to the sidebar by clicking and dragging.
 

Attachments

  • Screen Shot 2021-02-25 at 11.40.45 AM.png
    Screen Shot 2021-02-25 at 11.40.45 AM.png
    124.6 KB · Views: 0
Comment

Millard

Member
Messages
10
Reaction score
1
Click and drag doesn't work.

Would uninstall / reinstall fix it? And without deleting data (i.e. settings and linked threads)?
 
Comment

Alex

MD developer
Messages
5,522
Reaction score
1,443
No, uninstalling won't help as meta box order is saved to user preferences in the database and XFtoWP doesn't delete that (or any) data on install currently.

After a little review this is a surprisingly ongoing discussion regarding the new Gutenberg editor about drag and drop meta box inconsistencies. Luckily there seems to be a pending fix to make it more intuitive, but check out this visual guide to make sure you are dropping the meta box into one of the respected "hot zones" in the sidebar:

 
Comment

Millard

Member
Messages
10
Reaction score
1
Thank you for the link.

No luck with drag/drop into hot zone.

However, one of the commenters provided a solution:
With the same issue, I installed the Classic-Editor-Plugin, activated it, rearranged the metaboxes and then deactivated it.

 
Comment

Alex

MD developer
Messages
5,522
Reaction score
1,443
Thank you for the link.

No luck with drag/drop into hot zone.

However, one of the commenters provided a solution:


Nice, did that carry over after you deactivated the classic editor? I am going to take a few minutes right now as I finish up the XFtoWP 1.2 beta to see if there's a fix to make the thread features work regardless of position.
 
Comment

Alex

MD developer
Messages
5,522
Reaction score
1,443
Yes, it did!
Glad to hear. Thanks to your report and a little troubleshooting on my end I am very happy to say this issue has been fixed in XFtoWP1.2 and all functions will now work regardless of location in the Gutenberg editor!
 
Comment
Top