• Welcome to the official support community for the Marketers Delight WordPress theme. Most content here is private and to ask questions, get official support, and network with other WordPress users please register and verify your forum account to start posting today.

Bug: Scheduled threads are not created on post publish

Andro

Client
Messages
13
Reaction score
18
Hello,

An author has been regularly reporting his scheduled threads are not created on post publish.

Details he has provided are:
When the issue occurs, XenForo thread sidebar tab opens in collapsed mode, he then expands it and hit the Schedule thread button but even after the post is published XenForo thread tab shows the yellow notice which says 'Thread will create on publish'.

Screenshots for your reference: Screenshot 1, Screenshot 2

This is a serious bug due to which most of our scheduled threads are not created on time and unless I manually create them every time they aren't posted. (Note: The author can't even manually create threads using Create thread button after post publish - he says it doesn't work for him). His WordPress user role is Editor but I believe it happens for some other reason and affects other user groups also. Since this error doesn't happen to me, I can't provide any other details.
 

Alex

MD developer
Messages
5,522
Reaction score
1,443
It is a strange issue as I was just able to successfully schedule posts with the a test user with the Editor role. Just to be thorough, you do have the permission enabled in the admin settings?

Screen Shot 2021-04-14 at 4.28.51 PM.png

I also wonder if the cache plugin is not being cleared when editors publish. Just a thought to try to explain the inconsistency, but I am not currently seeing anything on the side of XFtoWP.
 
Comment

Andro

Client
Messages
13
Reaction score
18
Just to be thorough, you do have the permission enabled in the admin settings?
Yes. The above permission is checked for both editor and author user roles.

The user has provided some clue if that can be of any help:
When the issue occurs, XenForo thread sidebar tab opens in collapsed mode, he then expands it and hit the Schedule thread button but even after the post is published XenForo thread tab shows the yellow notice which says 'Thread will create on publish'.

I also wonder if the cache plugin is not being cleared when editors publish. Just a thought to try to explain the inconsistency
No idea. I had asked the user to try from a different browser including incognito/private mode to see if local cache playing a role but it doesn't work anywhere as per him. I can confirm it doesn't work because after post publish scheduled threads are not created for his posts.
 
Comment

Andro

Client
Messages
13
Reaction score
18
An update on this:
I logged into the author's account and found he has moved (drag n drop) the XenForo sidebar tab into the post area. I moved it back to the sidebar and it works fine for him.

Do you expect the XenForo tab to work fine on the post area as well since all WP plugin sidebar items can be dragged over there? If so, you can consider this as a bug.
 
Last edited:
Comment

Alex

MD developer
Messages
5,522
Reaction score
1,443
When the issue occurs, XenForo thread sidebar tab opens in collapsed mode, he then expands it and hit the Schedule thread button but even after the post is published XenForo thread tab shows the yellow notice which says 'Thread will create on publish'.
This happens after the post has auto scheduled or the editor publishes the post? I have found clicking Schedule, then publish the post doesn't show the correct message but it still publishes the thread. Try to make a test Editor account and refresh after manually publishing.
 
Comment

Andro

Client
Messages
13
Reaction score
18
This happens after the post has auto scheduled or the editor publishes the post?
Actually both.

I was trying to reposition the XFtoWP meta boxes to their original position (sidebar) to see if that works but on page refresh they were getting moved to their previous position (post content area). So I used a plugin called Reset Meta Box Positions which helped in resetting the meta boxes to their original positions. Now hoping the user will be able to publish threads from WP. Let's see...
 
Comment

Alex

MD developer
Messages
5,522
Reaction score
1,443
I was trying to reposition the XFtoWP meta boxes to their original position (sidebar) to see if that works but on page refresh they were getting moved to their previous position (post content area). So I used a plugin called Reset Meta Box Positions which helped in resetting the meta boxes to their original positions. Now hoping the user will be able to publish threads from WP. Let's see...
Ok, that is a likely issue and one that is fixed in the latest beta, and will soon be merged into the full plugin. :)
 
Comment
Top